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Integrated Development Environment e² studio 
How to use IAR Systems compiler in e² studio 
Introduction 
When you will use IAR Eclipse plugins on the e2 studio, you can create projects, set build options, and 
perform builds on the e2 studio using the IAR Systems compilers. 

This document describes the procedure for using the IAR Systems compiler on the e2 studio. 
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1. Overview 
1.1 Purpose 
When you will use IAR Eclipse plugins on the e2 studio, you can create projects, set build options, and 
perform builds on the e2 studio using the IAR Systems compilers. Therefore, to use the IAR Systems 
compiler on the e2 studio, you need to install IAR Embedded Workbench on your PC and then install the IAR 
Eclipse plugins on the e2 studio. 

This document describes the setup procedure for using IAR Systems compilers on the e2 studio, as well as 
the procedures for creating a project, setting build options, and executing the build using IAR Systems 
compilers. 

 As an example, the case of using IAR RX compiler on the e2 studio is described. 

 IAR Systems compiler supports various Renesas devices other than the RX family. Refer to the 
following page for supported devices and compilers. 
IAR Embedded Workbench for Eclipse 

 The basic procedures are the same when using compilers for devices other than the RX family. 
When using a compiler for non-RX family devices, please read to replace the device name and 
compiler name. 

 The e2 studio configurator for embedding Flexible Software Packages (FSP) into your system does 
not support IAR Systems compilers. If you want to operate FSP project for RA family or RZ family, 
please use a combination of the Renesas Advanced Smart Configurator (RASC) and the IAR 
Embedded Workbench instead of the e2 studio. For details such as installation procedures, please 
refer to the documentation on the FSP GitHub page for each device family. 

 

[IAR Eclipse plugins] 

IAR Eclipse plugins control IAR Systems compilers on the e2 studio, allowing you to create projects, set build 
options, and execute builds of IAR Systems compilers on the e2 studio. 

 

1.2 Environment 
This content is described based on the following environment: 

[OS] 

 OS    Windows10 64bits 

[Tool] 

 e2 studio   2023-07 

 IAR Eclipse plugins  IAR EW for Renesas RX 4.20.1 

 IAR Embedded Workbench (include RX Compiler) 

In advance, please install the e2 studio to your PC. 

 

Please note IAR Systems compilers are not evaluated with the e2 studio in Renesas. 

The technical support is provided by IAR Systems compilers, IAR Eclipse plugins, and C-SPY debuggers. 
Please ask IAR Systems (and its distributors) for detailed specifications and usage of these products. 

 

  

https://eclipse-update.iar.com/updatesites.html
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2. Install IAR Embedded Workbench 
Purchase or obtain IAR Embedded Workbench for Renesas RX (with RX compiler) from IAR Systems and 
install it. 

You can download the evaluation version of IAR Embedded Workbench for Renesas RX including RX 
compile from IAR Systems web site (https://www.iar.com/). However, user registration is required to 
download. 

If you want to create a project for devices other than the RX family, please purchase or obtain IAR 
Embedded Workbench for your device. 

 

  

https://www.iar.com/
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3. Install IAR Eclipse plugins 
This chapter describes how to install IAR Eclipse plugins to the e2 studio. 

 If the installation of the IAR Eclipse plugins fails, please download plugins by yourself from IAR 
Embedded Workbench for Eclipse and install it referring to the following page. 
How to Install a Generic Eclipse Plug-in on e² studio | Renesas Customer Hub 

1) Launch e2 studio after finish installing IAR Embedded Workbench. 

2) Select menu item [Help] > [IAR Embedded Workbench plugin manager…]. 

3) The [Progress Information] message is appeared, confirming the existing plugins. 

 
Figure 1 The [Progress Information] message 

4) The [IAR Embedded Workbench plugin manager] dialog is appeared after finish confirming the existing 
plugins. Click the "RX (>=4.10)" in the [Supported targets], check the "4.20.1" checkbox in [Available 
IAR Embedded Workbench installations]. And press the [Install] button. 

 
Figure 2 The [IAR Embedded Workbench plugin manager] dialog 

5) Start the download of the plugins. The download will proceed in the background. And the progress will 
be displayed on the status bar. Press the [Shows background operations in Progress view] button, 
[Progress] view is opened. 
Note: Download plugins takes time. 

 
Figure 3 The [Progress] view 

6) The [Install - Install] dialog is appeared after finish downloading plugins. Press the [Next >] button. 

https://eclipse-update.iar.com/updatesites.html
https://eclipse-update.iar.com/updatesites.html
https://en-support.renesas.com/knowledgeBase/20467645
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Figure 4 The [Install - Install] dialog 

7) The [Install - Install Details] dialog is appeared. Press the [Next >] button. 

 
Figure 5 The [Install - Install Details] dialog 

8) The [Install - Review Licenses] dialog is appeared. Accept terms of license agreement and press the 
[Finish] button in order to start the install of plugins. 
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Figure 6 The [Install - Review Licenses] dialog 

9) Start installing the plugins. The installation will proceed in the background. 
Note: Installing plugins takes time. 

10) The [Trust] message may be appeared during installation. Check the "PCG" checkbox and press the 
[Trust Selected] button. 

 
Figure 7 The [Trust] message 

11) When the installation is completed, the following message is appeared. Press the [Restart Now] button. 

 
Figure 8 The [Software Updates] message 

12) After restart e2 studio, select menu item [Help] > [IAR Embedded Workbench plugin manager…] again. 
If the plugins have been successfully installed, version number is displayed. Press the [Cancel] button. 
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Figure 9 The [IAR Embedded Workbench plugin manager] dialog 
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4. Create a project 
When IAR Eclipse plugins installation is complete, you can create a project for IAR Systems compiler, set 
Build options, and execute Build for that project. 

This chapter describes how to create a project. 

1) Select the menu [File] > [New] > [C/C++ Project]. 

2) In the [New C/C++ Project - Templates for New C/C++ Project] dialog, select "All" at the left side, then 
select "C Managed Build" (or "C++ Managed Build") at the right side. Press the [Next >] button. 

 
Figure 10 The [New C/C++ Project - Templates for New C/C++ Project] dialog 

3) The [C Project] dialog is appeared. Select "Executable (IAR) > Empty Project" or "Executable (IAR) > 
Project with empty main()" or "Library (IAR) > Empty Project" in the [Project type], input project name in 
the [Project name:] textbox. And press the [Next >] button. 

 "Executable (IAR) > Empty Project" 
This project is for generating an absolute file. In this project, there is no source file as default. 

 "Executable (IAR) > Project with empty main()" 
This project is for generating an absolute file. One source file containing the main function will be 
generated as default. 

 "Library (IAR) > Empty Project" 
This project is for generating a library file. In this project, there is no source file as default. 
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Figure 11 The [C Project] dialog 

4) The [Select Configurations] dialog is appeared. Press the [Next >] button. 

 
Figure 12 The [Select Configurations] dialog 

5) The [IAR Device Selection] dialog is appeared. Press the [Browse…] button and select a device which 
you use in your project. Press the [Finish] button. 
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Figure 13 The [IAR Device selection] dialog 

6) The created project is shown on the [Project Explorer] view. 
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5. Usage 
To set Build options for the Compiler, Assembler, Linker, and more, select your project in the [Project 
Explorer] view and perform one of the following operations. 

 Select the menu [Project] > [Properties]. 

 Select the context menu [C/C++ Project Settings]. 

 Select the context menu [Properties]. 

The [Properties] dialog is appered. Select "C/C++ Build > Settings" in the left side, click the [Tool Settings] 
tab. You can setup Build options. 

 
Figure 14 The [Properties: <project name>] dialog 

 

To execute the Build, select your project in the [Project Explorer] view and perform one of the following 
operations. 

 Select the [Build] button on the toolbar. 

 Select the menu [Project] > [Build Project]. 

 Select the context menu [Build Project] 

 

Notes: 
To use IAR Systems compiler, you need to register a license. If the license is not registered, the following 
error will occur at execute Build time. 

Fatal error[LMS001]: License check failed. Use the IAR License manager to resolve the 
problem. 

 

Register the license from "IAR License Manager". "IAR License Manager" is installed together with "IAR 
Embedded Workbench". 
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6. Reference information 
6.1 Web site 

 IAR Systems 
https://www.iar.com/ 

 

 

 

  

https://www.iar.com/
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General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 
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Notice 
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products 

and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your 
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use 
of these circuits, software, or information. 

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, 
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this 
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples. 

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, 
manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required. 

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any 
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering. 

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated below. 
 "Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home 

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc. 
 "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key 

financial terminal systems; safety control equipment; etc. 
Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas 
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to 
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space 
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics 
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product 
that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document. 

7. No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics 
hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but 
not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS 
ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING 
RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE, 
HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND 
ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT 
PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH 
RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO 
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. 

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas 
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such 
specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily 
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as 
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for 
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are 
responsible for evaluating the safety of the final products or systems manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas 
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of 
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
14. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas 

Electronics products. 

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled 
subsidiaries. 

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.  
(Rev.5.0-1  October 2020) 

 
Corporate Headquarters  Contact information 
TOYOSU FORESIA, 3-2-24 Toyosu, 
Koto-ku, Tokyo 135-0061, Japan 
www.renesas.com 

 For further information on a product, technology, the most up-to-date 
version of a document, or your nearest sales office, please visit: 
www.renesas.com/contact/. 

Trademarks   
Renesas and the Renesas logo are trademarks of Renesas Electronics 
Corporation. All trademarks and registered trademarks are the property 
of their respective owners. 

  

 

https://www.renesas.com/
https://www.renesas.com/contact/

	1. Overview
	1.1 Purpose
	1.2 Environment

	2. Install IAR Embedded Workbench
	3. Install IAR Eclipse plugins
	4. Create a project
	5. Usage
	6. Reference information
	6.1 Web site

	Revision History

