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RENESAS TOOL NEWS on July 1, 2005: RSO-HEW-050701D

The High-performance Embedded Workshop, 
an Integrated Development Environment, 

Revised to V.4.00.02

We have revised the High-performance Embedded Workshop, an integrated development 
environment, from V.4.00.01 to V.4.00.02. This product is an object of the update 
utility provided by the High-performance Embedded Workshop.

1. Product Concerned
The High-performance Embedded Workshop products bundled with the following tools 
are concerned:
(1) C compiler package for the M32R family

M3T-CC32R V.4.20 Release 1 through V.4.30 Release 00

(2) C compiler package for the M32C/90, M32C/80, and
M16C/80 series 
M3T-NC308WA V.5.20 Release 1 and V.5.20 Release 02

(3) C compiler package for the M16C/60, M16C/30,
M16C/20, M16C/10, M16C/Tiny, and 
R8C/Tiny series M3T-NC30WA V.5.20 Release 1 through
V.5.30 Release 02

(4) C compiler packages for the R8C/Tiny series (freeware
products)
M3T-NC30WA V.5.20 Release 1 and V.5.30 Release 02
M3T-NC8C V.5.30 Release 1

(5) Debugger package for the M16C/60, M16C/30,
M16C/20, M16C/10, M16C/Tiny, and 
R8C/Tiny series 
M16C R8C V.1.00 Release 00 and V.1.00 Release 01

(6) Compact emulator for the M32C/84, M32C/85, and
M32C/86 group
M30850T2-CPE



(7) Compact emulator for the M32C/87 group
M30870T2-CPE

(8) Compact emulator for the M30260 MCU, M16C/26A
group, M16C/Tiny series
M30260T2-CPE-GP

(9) Compact emulator for the M30263 MCU, M16C/26A
group, M16C/Tiny series
M30263T2-CPE-FP

(10) Compact emulator for the M30280 MCU, M16C/28 group
and the M30290, M16C/29 
group, M16C/Tiny series 
M30290T2-CPE-HP

(11) Compact emulator for the M30281 MCU, M16C/28 group
and the M30291, M16C/29
group, M16C/Tiny series
M30291T2-CPE-HP

(12) Compact emulators for the H8/300H Tiny series 
R0E436640CPE10
R0E436640CPE20

(13) The C/C++ compiler package V.7.1.01 through V.9.00
Release 02
for the SuperH RISC engine family

(14) The C/C++ compiler package V.5.0.03 through V.6.01
Release 00
for the H8, H8S, and H8SX families

(15) The E10A-USB emulators
HS0005KCU01H
HS0005KCU02H
NOTICE: Please refer to Section 4, (To the Users Who
are Using the E10A-USB
emulator) in RENESAS TOOL NEWS No. RSO-HEW-
050126D, issued on January 26,
2005.

(16) The E7 emulator
HS0007TCU01H

(17) The E8 emulator
R0E000080KCE00

(18) E6000H emulators



All the versions for the High-performance Embedded
Workshop

(19) E6000 emulators
All the versions for the High-performance Embedded
Workshop

(20) E10A emulators
All the versions for the High-performance Embedded
Workshop

(21) The E10T emulators

(22) The E10T-USB emulator
HS0005TCU01H

(23) The E200F emulators
R0E0200F0EMU00
R0E0200F1EMU00

2. Functions Introduced and Improved

2.1 For All the Products Concerned
(1) The Collapse and Expand/Collapse commands have

been introduced to the pop-up menu that appears in
the window displayed by clicking the Projects tab in
the Workspace window.

(2) Two or more files selected in the Projects tab in the
Workspace window can be removed from a build, or
the removed files can be returned to the build.*
To perform these operations, the Include/Exclude
Build command have been added to the Build menu.
* To remove or return files, select any file and right-
click it; a pop-up menu appears. On this menu, select
the Include/Exclude Build command.

(3) The Properties command has been introduced to the
pop-up menu that appears in the Editor window
displayed in Source mode. This command is capable
of providing the name of a file, its path name, and its
updated date in the Editor window.

(4) The Display PC command, which is used for
displaying the indication of the program counter (PC),
has been introduced to the pop-up menu that
appears in the Editor window displayed in MIX or
Disassembly mode and in the Disassembly window.*



* To open the Disassembly window, click the menu
name of View and select the Disassembly command.

(5) The names of the files not included in the directory
where the active project files reside can only be
displayed on the Title bar in absolute path
representation with the file names viewed in the
Editor window* being used.
* To view these file names, double-click those
displayed in the Projects tab in the Workspace
window.

(6) The font size used in the Disassembly window has
been changed from 11 points to 10.

(7) Two keyboard shortcuts have been assigned to
commands in the pop-up menu that appears in the
Output window when the build tab is selected. The
commands and their keyboard shortcuts are as
follows:

Command
Keyboard
Shortcut

Display next
Error/Warning

F8

Display previous
Error/Warning

Shift+F8

(8) The names of the files containing the errors or
warnings that are displayed in the Output window by
executing the command(s) in (7) above are shown in
the Editor window.

(9) The Refresh command has been introduced to the
pop-up menu that appears in the IO window. This
command is used for updating the contents of the IO
window.

(10) The Reset Positions button has been introduced to
the Toolbar tab in the Customize dialog box.* This
button is used for initializing the position of the
toolbar when the Toolbar tab is selected.
* To see this dialog box, open the Setup menu and
select the Customize command.

(11) The Toolchain install directory command has been



introduced to the pop-up menu that appears by
clicking the Placeholder button to the right of the Edit
field in the New Build Phase dialog box (Step 3).*
* To see this dialog box, click the Add button in the
Build Phases dialog box. To see the Build Phases
dialog box, open the Build menu and select the Build
Phases command.

(12) The Name, Company website/Your application, and
Country edit boxes have been introduced to the
Submit a Bug Report dialog box.*
* To see this dialog box, open the Help menu and
select the Technical Support -> Create Bug Report
command.

(13) When you want to close the Command Line window*
during executing a command file (a batch file), the
message box is displayed which asks you whether to
terminate the execution of the batch file forcefully.
* To open this window, click the menu name of View
and select the Command Line command.

(14) Mode 7 (STEP_RATE 7) has been introduced, which
prohibits the Editor window from being refreshed
when step execution is performed by entering the
STEP_RATE command in the Command Line window.
Example of entry

---------------------
>STEP_RATE 7
---------------------

2.2 For the Products Listed in Items (13) and (14) in Section 1
(1) The MemoryMap Setting and Memory Resource Auto

Allocate commands have been introduced to the pop-
up menu that appears by right-clicking an unoccupied
area of the Map window.* These commands are used
for setting memory maps and automatically reserving
memory resources, respectively.
* To open this window, click the menu name of View
and select the Map command.

2.3 For the Products Listed in Items (13) Through (23) in Section 1
(1) The following commands of watch functions have been



introduced. For details of their parameters, see the
online help (*1) of the High-performance Embedded
Workshop.

Command Name Description

WATCH_ADD Adds Watch items.

WATCH_AUTO_UPDATE
Sets/resets auto-
update of Watch items.

WATCH_DELETE Removes Watch items.

WATCH_DISPLAY
Displays contents of
Watch window. (*2)

WATCH_EDIT
Edits values of Watch
items.

WATCH_EXPAND
Expands/compresses
Watch items.

WATCH_RADIX
Changes radix for
displaying Watch
items.

WATCH_SAVE
Saves contents of
Watch window on a
file.

*1. To open this help, click the menu name of Help and
select the Help Topics command.
*2. To open this window, click the menu name of View
and select the Symbol -> Watch command.

(2) The Match whole word only option has been introduced
to the Find Label dialog box.*
* To see this dialog box, open the pop-up menu that
appears in the Labels window and select the Find
command. To open the Labels window, click the menu
name of View and select the Symbol -> Labels
command.

2.4 For the HS0AE5EPH60H in Item (18) and the HS0AE4EPI61H and HS0AE4XEPI61H in
Item (19) in Section 1

An error message appears if any of the following code coverage commands is typed
during executing the user program:

COVERAGE_CLEAR, COVERAGE_DISPLAY, COVERAGE_LOAD, 



COVERAGE_RANGE, and COVERAGE_SAVE
2.5 For the Products Listed in Items (15), (18), (19), and (23) in Section 1

When the format of name <monitor-window name (monitor point name)> is typed at
entering parameters of the MONITOR_SET command accompanied with keywords, the
format is automatically interpreted as parameters with keywords. So, if you need to
enter such parameters, be sure to type "name <monitor-window name>."
NOTICES:
1. For the products in item (15), the above improvement

is valid only when any MCUs in the New_SH-Mobile,
SH-4A, and SH-2A device groups are targeted for
debugging.

2. Among the products in item (19), the following are
involved in the above improvement only when they are
targeted with the optional bus-monitoring board being
connected to the E6000 emulator:
HS2195EPI60H, HS3008EPI60H, HS3644EPI60H,
HS3L08EPI60H, HS388REPI60H, and HS3800EPI60H

Example: MONITOR_SET name monitor1 ffb400 20 format byte

NOTE:
Command line syntax at entering parameters with keywords
name <monitor-window name> [<address> <size>] [format <format>]
[type <type>] [rate <refresh_rate>][initial_value <state>] [detail <user specific value
according to respective Target Emulator>] Here, [ ] denotes an omissible parameter.

3. Problems Fixed

3.1 For All the Products Concerned
The following problems have been fixed:
(1) On using custom placeholders

For details, see RENESAS TOOL NEWS Doc. No. RSO-HEW_2-050616D, issued
on June 16, 2005.

(2) On highlighting no error message lines
After clicking the Build tab in the Output window, right-click an unoccupied are of
the window. A pop-up menu appears. In this menu, if you select the Display next
Error/Warning or Display previous Error/Warning command, no error message
lines displayed in the Output window may be highlighted.

(3) On incorrect registration of character strings in Microsoft(R) Visual SourceSafe
(VSS)
When VSS is selected as the version-administrating tool, uppercase letters that



are contained in the project names and the file names of the projects entered at
logging into VSS* are registered as lowercases on VSS.
* The window for logging into VSS is opened as

follows:
Open the Tools menu and select the Version Control
-> Select command. 
The Select Version Control System dialog box
appears. In this dialog box, select VSS out of the
Version control systems list; then click the OK
button.

(4) On incorrectly displaying function pointers on a C++ Classes category tree 
When you click the Navigation tab in the Workspace window and then expand
the C++ Classes category tree* in the window in order to display function
pointers defined in a source file, incorrect results may be obtained. For example,
source code "long (*proc)();" is displayed on a C++ Classes category tree not as
a function name but as only "()" or "(*proc)()."
* This category tree can be displayed as follows:

(1) Click the Navigation tab in the Workspace
window; then right- click an unoccupied
area of the window. A pop-up menu
appears.

(2) In this menu, select the Select Categories
command. A dialog box opens, in which
check the C++ Classes check box.

(5) On incorrectly displaying variables of type structure array
When you click the Navigation tab in the Workspace window and then expand
the C++ Classes category tree* in the window in order to display variables of
type structure array defined in a source file, codes other than the variables may
be displayed in addition.
When the source code shown in Example below is displayed on a C++ Classes
category tee, for example, '[', ']', and '3' are displayed in addition to the variable
of type structure array "rate."
Example:
--------------------------------------------------------------- 
struct name {
char str;
} rate[3];
---------------------------------------------------------------

(6) On label names remaining undeleted in the Disassembly window
When the combination with the debugging platform is disabled and then enabled,



the label names that would be deleted remain displayed in the Disassembly
window.

(7) On the yellow right arrow that points to the indication of the program counter
(PC) remaining undeleted in the Editor window
Even if downloaded modules are unloaded, the yellow right arrow that points to
the indication of PC will not be deleted. Or, if the combination with the debugging
platform is disabled and then enabled, the yellow right arrow that points to the
indication of PC will not disappear.

(8) On displaying error message "Out of memory" in Windows Me
Any product concerned is executed in the host PC running Windows Me, error
message "Out of memory" appears when My Computer or My Network Places is
selected out of the Look in pull- down menu in the Open file dialog box.*
* To see this dialog box, open the File menu and select the Open command.

(9) On searching for a character string in the right pane of the Difference window
If you click a file to compare in the right pane of the Difference window* and click
the Find button on the toolbar to search for a character string, it can only be
searched for in the left pane and not in the right pane.
* To open this window, click the menu name of Tools

and select the Show Differences command. A dialog
box appears, into which enter the names of the files
to compare and to be compare.

3.2 For the Products Listed in Items (5) and (12)
The following problem has been fixed:
On switching between sessions after opening the RAM monitor window
The High-performance Embedded Workshop may be shut down if you switch between
sessions after opening the RAM monitor window.*
* To open this window, click the menu name of View and select the CPU ->
RamMonitor command.

3.3 For the Products Listed in Items (13) through (23)
The following problems have been fixed:
(1) On reconnection to the debugging platform

For details, see RENESAS TOOL NEWS Doc. No. RSO-HEW_1-050616D, issued
on June 16, 2005.

(2) On displaying address data outside the range of memory mapping in the Memory
window
If address data outside the range of memory mapping is displayed in the Memory
window,* incorrect values will be shown. And if the Memory window is scrolled
or values in memory are edited under the above condition, values displayed in
the window fluctuate irregularly.
* To open this window, click the menu name of View and select the CPU ->



Memory command.

(3) On incorrectly displaying or editing the values of bit symbols When load modules
created in the ELF/DWARF2 format is debugged, the values of bit symbols are
incorrectly displayed or edited in the Watch window. (*1)
The same are the cases where the instant watch (*2) or tool-chip 
watch utilities (*3) are used.

Example bit symbol definitions (H8C)
 ---------------------------------------------------------------
                 .CPU    2600A:32
         AD1     .EQU    H'00FFFF00
         AD2     .EQU    H'00FFF800
         AD1B0   .BEQU   0,AD1            <- Bit symbol
         AD1B1   .BEQU   1,AD1            <- Bit symbol
         AD2B2   .BEQU   2,AD2            <- Bit symbol
         AD2B3   .BEQU   3,AD2            <- Bit symbol

                 .SECTION        A,CODE,ALIGN=2
                 BSET.B  AD1B0
                 BSET.B  AD1B1
                 BSET.B  AD2B2
                 BSET.B  AD2B3

                 .export         _main
         _main:
                 rts
                 .end
---------------------------------------------------------------

*1. To open this window, click the menu name of View
and select the Symbol -> Watch command.

*2. To use this utility, follow these steps:

(1) After selecting any symbol in the Editor
window, right-click an unoccupied area in
the window. A pop-up menu opens.

(2) In this menu, select the Instant Watch
command.

*3. To use this utility, hover the mouse pointer over
any symbol in the Editor window.

3.4 For the Products Listed in Items (15), (18), (19), and (23) in Section 1



The following problem has been fixed: 
On setting the monitor
For details, see RENESAS TOOL NEWS Doc. No. RSO-HEW_2-050416D, issued on April
16, 2005.

NOTICES:
(1) For the products in item (15), the above problem

arises only when any MCUs in the New_SH-Mobile,
SH-4A, and SH-2A device groups are targeted for
debugging.

(2) Among the products in item (19), the following are
involved in the above problem only when they are
targeted with the optional bus-monitoring board being
connected to the E6000 emulator:
HS2195EPI60H, HS3008EPI60H, HS3644EPI60H,
HS3L08EPI60H,
HS388REPI60H, and HS3800EPI60H

3.5 For the Products Listed in Items (15), (18), (19), and (23) in Section 1
The following problem has been fixed:
On the circle remaining in the Event column in the Disassembly window In the
Disassembly window, right-click the Event column* displayed during using the
debugging platform. A pop-up menu appears.
In this menu, select the Delete All command. And the circle in the Event column may
not be deleted.
* To display this column name, hover the mouse

pointer over the blank column to the left of the Editor
window.

4. How to Update Your Product
Free-of-charge online revision is available. To update yours download the update program
from HERE ; then execute it.

5. Notices
(1) If you have not already installed the High-performance

Embedded Workshop V.2.2 or later, you cannot update
your High-performance Embedded Workshop to
V.4.00.02.

(2) No components except the High-performance



Embedded Workshop (for example, C compilers,
emulators, etc.) are affected by this update.

(3) In order to update the High-performance Embedded
Workshop bundled with the C/C++ compiler package
for the SuperH RISC engine family, the compiler
package must be updated to V.7.1.03 or V.7.1.04 in
advance; then update the High-performance
Embedded Workshop to V.4.00.02.
So, the C/C++ compiler package for the H8, H8S, and
H8SX families must be updated to V.5.0.05 or V.5.0.06
before updating the High-performance Embedded
Workshop.
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